Nasıl kullanılır
- Giriş alanına IPv4 veya IPv6 adresinizi CIDR biçiminde yazın.
- Adrese /24 gibi bir önek eklemediyseniz Önek listesinden ağınızın önekini seçin.
- İkili gösterimi göster seçeneği kapalıysa işaretleyin; IPv4 adresi, maske ve ağ ikili olarak gösterilir, ağ bitlerinin altı çizilir.
- Ağı daha küçük alt ağlara ayırmak için Alt ağlara böl listesinden daha uzun bir önek seçin.
Örnekler
Ofisteki bir cihazın ağını bulma
192.168.1.10/24
Adres: 192.168.1.10 Ağ: 192.168.1.0/24 Ağ maskesi: 255.255.255.0 Wildcard maskesi: 0.0.0.255 Yayın (broadcast): 192.168.1.255 İlk kullanılabilir host: 192.168.1.1 Son kullanılabilir host: 192.168.1.254 Toplam adres: 256 Kullanılabilir host: 254 Adres türü: Özel (RFC 1918) Eski sınıf: C Tam sayı: 3232235786 Hex: 0xC0A8010A Host bitleri ayarlanmış. Ağ: 192.168.1.0/24.
Şirket ağını /24 alt ağlara ayırma
10.20.0.0/16
Adres: 10.20.0.0 Ağ: 10.20.0.0/16 Ağ maskesi: 255.255.0.0 Wildcard maskesi: 0.0.255.255 Yayın (broadcast): 10.20.255.255 İlk kullanılabilir host: 10.20.0.1 Son kullanılabilir host: 10.20.255.254 Toplam adres: 65536 Kullanılabilir host: 65534 Adres türü: Özel (RFC 1918) Eski sınıf: A Tam sayı: 169082880 Hex: 0x0A140000 256 × /24 alt ağ 10.20.0.0/24 | 10.20.0.1 – 10.20.0.254 | 10.20.0.255 | 254 … 10.20.255.0/24 | 10.20.255.1 – 10.20.255.254 | 10.20.255.255 | 254
IPv6 deneme ağını /64 alt ağlara ayırma
2001:db8:1234::/56
Adres: 2001:db8:1234:: Genişletilmiş: 2001:0db8:1234:0000:0000:0000:0000:0000 Ağ: 2001:db8:1234::/56 Önek maskesi: ffff:ffff:ffff:ff00:: Adres aralığı: 2001:db8:1234:: – 2001:db8:1234:ff:ffff:ffff:ffff:ffff Toplam adres: 4722366482869645213696 (2^72) Adres türü: Dokümantasyon (RFC 3849) 256 × /64 alt ağ 2001:db8:1234::/64 | 2001:db8:1234:: – 2001:db8:1234:0:ffff:ffff:ffff:ffff | 18446744073709551616 … 2001:db8:1234:ff::/64 | 2001:db8:1234:ff:: – 2001:db8:1234:ff:ffff:ffff:ffff:ffff | 18446744073709551616
IPv4 alt ağ maskesi tablosu
/0 – /32 tablosunu göster
| Önek | Ağ maskesi | Wildcard | Adres sayısı | Kullanılabilir host |
|---|---|---|---|---|
| /0 | 0.0.0.0 | 255.255.255.255 | 4294967296 | 4294967294 |
| /1 | 128.0.0.0 | 127.255.255.255 | 2147483648 | 2147483646 |
| /2 | 192.0.0.0 | 63.255.255.255 | 1073741824 | 1073741822 |
| /3 | 224.0.0.0 | 31.255.255.255 | 536870912 | 536870910 |
| /4 | 240.0.0.0 | 15.255.255.255 | 268435456 | 268435454 |
| /5 | 248.0.0.0 | 7.255.255.255 | 134217728 | 134217726 |
| /6 | 252.0.0.0 | 3.255.255.255 | 67108864 | 67108862 |
| /7 | 254.0.0.0 | 1.255.255.255 | 33554432 | 33554430 |
| /8 | 255.0.0.0 | 0.255.255.255 | 16777216 | 16777214 |
| /9 | 255.128.0.0 | 0.127.255.255 | 8388608 | 8388606 |
| /10 | 255.192.0.0 | 0.63.255.255 | 4194304 | 4194302 |
| /11 | 255.224.0.0 | 0.31.255.255 | 2097152 | 2097150 |
| /12 | 255.240.0.0 | 0.15.255.255 | 1048576 | 1048574 |
| /13 | 255.248.0.0 | 0.7.255.255 | 524288 | 524286 |
| /14 | 255.252.0.0 | 0.3.255.255 | 262144 | 262142 |
| /15 | 255.254.0.0 | 0.1.255.255 | 131072 | 131070 |
| /16 | 255.255.0.0 | 0.0.255.255 | 65536 | 65534 |
| /17 | 255.255.128.0 | 0.0.127.255 | 32768 | 32766 |
| /18 | 255.255.192.0 | 0.0.63.255 | 16384 | 16382 |
| /19 | 255.255.224.0 | 0.0.31.255 | 8192 | 8190 |
| /20 | 255.255.240.0 | 0.0.15.255 | 4096 | 4094 |
| /21 | 255.255.248.0 | 0.0.7.255 | 2048 | 2046 |
| /22 | 255.255.252.0 | 0.0.3.255 | 1024 | 1022 |
| /23 | 255.255.254.0 | 0.0.1.255 | 512 | 510 |
| /24 | 255.255.255.0 | 0.0.0.255 | 256 | 254 |
| /25 | 255.255.255.128 | 0.0.0.127 | 128 | 126 |
| /26 | 255.255.255.192 | 0.0.0.63 | 64 | 62 |
| /27 | 255.255.255.224 | 0.0.0.31 | 32 | 30 |
| /28 | 255.255.255.240 | 0.0.0.15 | 16 | 14 |
| /29 | 255.255.255.248 | 0.0.0.7 | 8 | 6 |
| /30 | 255.255.255.252 | 0.0.0.3 | 4 | 2 |
| /31 | 255.255.255.254 | 0.0.0.1 | 2 | 2 |
| /32 | 255.255.255.255 | 0.0.0.0 | 1 | 1 |
/31 ağları iki kullanılabilir adresli noktadan noktaya bağlantılardır (RFC 3021); /32 tek bir hosttur.
Sık sorulan sorular
/31 ve /32 ağlarda kaç kullanılabilir IP adresi vardır?
IPv4 /31 ağında iki adres de kullanılabilir; broadcast adresi yoktur. /32 ise tek bir host adresini belirtir.
IPv6 için broadcast adresi hesaplanır mı?
IPv6'da broadcast adresi yoktur. Araç, öneğin kapsadığı adres aralığını gösterir; bu aralıktaki tüm adresler atanabilir.
255.0.255.0 neden geçerli bir alt ağ maskesi değil?
Alt ağ maskesindeki 1 bitleri kesintisiz olmalıdır; 255.0.255.0 bu kurala uymaz. Noktalı alt ağ maskesi yalnızca IPv4 için kullanılabilir.
Alt ağlara bölme işleminde sınır var mı?
Mevcut önekten en fazla 16 bit daha uzun bir öneğe bölebilirsiniz. Sonuç tablosu ilk 1.024 alt ağı, CSV dosyası ise en fazla 65.536 satırı içerir.
Girdiğim IP adresi sunucuya gönderilir mi?
Hesaplama tarayıcınızda yapılır; girdiğiniz adres sunucuya gönderilmez. Adres, URL'nin # bölümüne yazıldığı için tarayıcı geçmişinde ve kopyalanan bağlantılarda kalır. Üretim sitesinde Google Analytics kullanım olayları gönderilir, ancak bu olaylar yalnızca araç adını içerir, girdiğiniz adresi içermez.