Zum Inhalt springen

Subnetzrechner

Netz, Broadcast und Host-Bereich aus CIDR oder Netzmaske berechnen.

IP-Adresse mit Präfix eingeben, z. B. 192.168.1.0/24.
Läuft im Browser – Ihre Daten werden nicht hochgeladen.

So funktioniert’s

  1. Geben Sie eine IPv4- oder IPv6-Adresse in das Eingabefeld ein.
  2. Wählen Sie unter „Präfix“ die Netzgröße, falls Ihre Eingabe kein Präfix enthält.
  3. Wählen Sie unter „Aufteilen in“ ein längeres Präfix, um kleinere Subnetze zu berechnen.
  4. Aktivieren Sie für IPv4 „Binär anzeigen“, um Adresse, Netzmaske und Netzwerk binär zu prüfen.

Beispiele

Büro-PC mit ausgeschriebener Netzmaske

Eingabe
172.16.5.4 255.255.240.0
Ausgabe
Adresse: 172.16.5.4
Netzwerk: 172.16.0.0/20
Netzmaske: 255.255.240.0
Wildcard-Maske: 0.0.15.255
Broadcast: 172.16.15.255
Erster nutzbarer Host: 172.16.0.1
Letzter nutzbarer Host: 172.16.15.254
Adressen gesamt: 4096
Nutzbare Hosts: 4094
Adresstyp: Privat (RFC 1918)
Klasse (veraltet): B
Ganzzahl: 2886731012
Hex: 0xAC100504
Host-Bits sind gesetzt. Das Netzwerk ist 172.16.0.0/20.

Privates Firmennetz in /16-Subnetze aufteilen

Eingabe
10.0.0.0/8
Ausgabe
Adresse: 10.0.0.0
Netzwerk: 10.0.0.0/8
Netzmaske: 255.0.0.0
Wildcard-Maske: 0.255.255.255
Broadcast: 10.255.255.255
Erster nutzbarer Host: 10.0.0.1
Letzter nutzbarer Host: 10.255.255.254
Adressen gesamt: 16777216 (2^24)
Nutzbare Hosts: 16777214
Adresstyp: Privat (RFC 1918)
Klasse (veraltet): A
Ganzzahl: 167772160
Hex: 0x0A000000

256 × /16-Subnetze
10.0.0.0/16 | 10.0.0.1 – 10.0.255.254 | 10.0.255.255 | 65534
…
10.255.0.0/16 | 10.255.0.1 – 10.255.255.254 | 10.255.255.255 | 65534

IPv6-Verbindung zwischen zwei Routern

Eingabe
2001:db8:1::/127
Ausgabe
Adresse: 2001:db8:1::
Ausgeschrieben: 2001:0db8:0001:0000:0000:0000:0000:0000
Netzwerk: 2001:db8:1::/127
Präfixmaske: ffff:ffff:ffff:ffff:ffff:ffff:ffff:fffe
Adressbereich: 2001:db8:1:: – 2001:db8:1::1
Adressen gesamt: 2
Adresstyp: Dokumentation (RFC 3849)
Punkt-zu-Punkt-Verbindung (RFC 6164): /127 wird für Verbindungen zwischen zwei Routern verwendet.

IPv4-Subnetzmasken-Übersicht

Tabelle für /0 – /32 anzeigen
PräfixNetzmaskeWildcardAdressenNutzbare Hosts
/00.0.0.0255.255.255.25542949672964294967294
/1128.0.0.0127.255.255.25521474836482147483646
/2192.0.0.063.255.255.25510737418241073741822
/3224.0.0.031.255.255.255536870912536870910
/4240.0.0.015.255.255.255268435456268435454
/5248.0.0.07.255.255.255134217728134217726
/6252.0.0.03.255.255.2556710886467108862
/7254.0.0.01.255.255.2553355443233554430
/8255.0.0.00.255.255.2551677721616777214
/9255.128.0.00.127.255.25583886088388606
/10255.192.0.00.63.255.25541943044194302
/11255.224.0.00.31.255.25520971522097150
/12255.240.0.00.15.255.25510485761048574
/13255.248.0.00.7.255.255524288524286
/14255.252.0.00.3.255.255262144262142
/15255.254.0.00.1.255.255131072131070
/16255.255.0.00.0.255.2556553665534
/17255.255.128.00.0.127.2553276832766
/18255.255.192.00.0.63.2551638416382
/19255.255.224.00.0.31.25581928190
/20255.255.240.00.0.15.25540964094
/21255.255.248.00.0.7.25520482046
/22255.255.252.00.0.3.25510241022
/23255.255.254.00.0.1.255512510
/24255.255.255.00.0.0.255256254
/25255.255.255.1280.0.0.127128126
/26255.255.255.1920.0.0.636462
/27255.255.255.2240.0.0.313230
/28255.255.255.2400.0.0.151614
/29255.255.255.2480.0.0.786
/30255.255.255.2520.0.0.342
/31255.255.255.2540.0.0.122
/32255.255.255.2550.0.0.011

/31-Netze sind Punkt-zu-Punkt-Verbindungen (RFC 3021) mit zwei nutzbaren Adressen; /32 ist ein einzelner Host.

Häufige Fragen

Wie viele nutzbare Hosts hat ein IPv4-Subnetz?

Bei /0 bis /30 werden Netzadresse und Broadcast abgezogen: Ein /24-Netz hat daher 254 nutzbare Hosts. Bei /31 sind beide Adressen nutzbar; /32 bezeichnet einen einzelnen Host.

Warum wird meine Subnetzmaske nicht akzeptiert?

Eine IPv4-Netzmaske muss zusammenhängende 1-Bits haben. 255.255.240.0 ist gültig, 255.0.255.0 nicht; ausgeschriebene Netzmasken werden nur für IPv4 unterstützt.

Hat ein IPv6-Subnetz eine Broadcast-Adresse?

IPv6 hat keine Broadcast-Adresse. Der Rechner zeigt stattdessen den gesamten Adressbereich an, denn jede Adresse im Bereich kann vergeben werden.

Wie viele Subnetze werden bei einer Aufteilung angezeigt?

Die Tabelle zeigt höchstens 1.024 Subnetze, der CSV-Export enthält bis zu 65.536 Zeilen. Das Zielpräfix darf höchstens 16 Bits länger sein als das Ausgangspräfix.

Wird meine eingegebene IP-Adresse an einen Server gesendet?

Die Berechnung läuft im Browser und sendet die Adresse nicht an einen Server. Die Adresse steht jedoch im URL-Fragment hinter # und bleibt dadurch im Browserverlauf sowie in kopierten Links erhalten.