Mode d'emploi
- Saisissez une adresse IPv4 ou IPv6, avec ou sans préfixe CIDR, dans le champ de saisie.
- Si vous n’avez pas indiqué de préfixe, sélectionnez-le dans « Préfixe ».
- Pour créer des sous-réseaux plus petits, choisissez leur préfixe dans « Diviser en ».
- Pour examiner les bits d’une adresse IPv4, cochez « Afficher en binaire ».
Exemples
Vérifier le sous-réseau d’un poste de bureau
192.168.1.10/24
Adresse: 192.168.1.10 Réseau: 192.168.1.0/24 Masque réseau: 255.255.255.0 Masque générique (wildcard): 0.0.0.255 Broadcast: 192.168.1.255 Premier hôte utilisable: 192.168.1.1 Dernier hôte utilisable: 192.168.1.254 Nombre total d'adresses: 256 Hôtes utilisables: 254 Type d'adresse: Privée (RFC 1918) Classe historique: C Entier: 3232235786 Hex: 0xC0A8010A Des bits d'hôte sont définis. Le réseau est 192.168.1.0/24.
Découper un réseau privé en sous-réseaux /16
10.0.0.0/8
Adresse: 10.0.0.0 Réseau: 10.0.0.0/8 Masque réseau: 255.0.0.0 Masque générique (wildcard): 0.255.255.255 Broadcast: 10.255.255.255 Premier hôte utilisable: 10.0.0.1 Dernier hôte utilisable: 10.255.255.254 Nombre total d'adresses: 16777216 (2^24) Hôtes utilisables: 16777214 Type d'adresse: Privée (RFC 1918) Classe historique: A Entier: 167772160 Hex: 0x0A000000 256 sous-réseaux /16 10.0.0.0/16 | 10.0.0.1 – 10.0.255.254 | 10.0.255.255 | 65534 … 10.255.0.0/16 | 10.255.0.1 – 10.255.255.254 | 10.255.255.255 | 65534
Découper un préfixe IPv6 /48 en réseaux /64
2001:db8:1234::/48
Adresse: 2001:db8:1234:: Forme développée: 2001:0db8:1234:0000:0000:0000:0000:0000 Réseau: 2001:db8:1234::/48 Masque du préfixe: ffff:ffff:ffff:: Plage d'adresses: 2001:db8:1234:: – 2001:db8:1234:ffff:ffff:ffff:ffff:ffff Nombre total d'adresses: 1208925819614629174706176 (2^80) Type d'adresse: Documentation (RFC 3849) 65 536 sous-réseaux /64 2001:db8:1234::/64 | 2001:db8:1234:: – 2001:db8:1234:0:ffff:ffff:ffff:ffff | 18446744073709551616 … 2001:db8:1234:3ff::/64 | 2001:db8:1234:3ff:: – 2001:db8:1234:3ff:ffff:ffff:ffff:ffff | 18446744073709551616 Affichage des 1 024 premiers sous-réseaux sur 65 536.
Référence des masques de sous-réseau IPv4
Afficher le tableau de /0 à /32
| Préfixe | Masque réseau | Masque générique | Adresses | Hôtes utilisables |
|---|---|---|---|---|
| /0 | 0.0.0.0 | 255.255.255.255 | 4294967296 | 4294967294 |
| /1 | 128.0.0.0 | 127.255.255.255 | 2147483648 | 2147483646 |
| /2 | 192.0.0.0 | 63.255.255.255 | 1073741824 | 1073741822 |
| /3 | 224.0.0.0 | 31.255.255.255 | 536870912 | 536870910 |
| /4 | 240.0.0.0 | 15.255.255.255 | 268435456 | 268435454 |
| /5 | 248.0.0.0 | 7.255.255.255 | 134217728 | 134217726 |
| /6 | 252.0.0.0 | 3.255.255.255 | 67108864 | 67108862 |
| /7 | 254.0.0.0 | 1.255.255.255 | 33554432 | 33554430 |
| /8 | 255.0.0.0 | 0.255.255.255 | 16777216 | 16777214 |
| /9 | 255.128.0.0 | 0.127.255.255 | 8388608 | 8388606 |
| /10 | 255.192.0.0 | 0.63.255.255 | 4194304 | 4194302 |
| /11 | 255.224.0.0 | 0.31.255.255 | 2097152 | 2097150 |
| /12 | 255.240.0.0 | 0.15.255.255 | 1048576 | 1048574 |
| /13 | 255.248.0.0 | 0.7.255.255 | 524288 | 524286 |
| /14 | 255.252.0.0 | 0.3.255.255 | 262144 | 262142 |
| /15 | 255.254.0.0 | 0.1.255.255 | 131072 | 131070 |
| /16 | 255.255.0.0 | 0.0.255.255 | 65536 | 65534 |
| /17 | 255.255.128.0 | 0.0.127.255 | 32768 | 32766 |
| /18 | 255.255.192.0 | 0.0.63.255 | 16384 | 16382 |
| /19 | 255.255.224.0 | 0.0.31.255 | 8192 | 8190 |
| /20 | 255.255.240.0 | 0.0.15.255 | 4096 | 4094 |
| /21 | 255.255.248.0 | 0.0.7.255 | 2048 | 2046 |
| /22 | 255.255.252.0 | 0.0.3.255 | 1024 | 1022 |
| /23 | 255.255.254.0 | 0.0.1.255 | 512 | 510 |
| /24 | 255.255.255.0 | 0.0.0.255 | 256 | 254 |
| /25 | 255.255.255.128 | 0.0.0.127 | 128 | 126 |
| /26 | 255.255.255.192 | 0.0.0.63 | 64 | 62 |
| /27 | 255.255.255.224 | 0.0.0.31 | 32 | 30 |
| /28 | 255.255.255.240 | 0.0.0.15 | 16 | 14 |
| /29 | 255.255.255.248 | 0.0.0.7 | 8 | 6 |
| /30 | 255.255.255.252 | 0.0.0.3 | 4 | 2 |
| /31 | 255.255.255.254 | 0.0.0.1 | 2 | 2 |
| /32 | 255.255.255.255 | 0.0.0.0 | 1 | 1 |
Les réseaux /31 sont des liaisons point à point (RFC 3021) avec deux adresses utilisables ; /32 correspond à un seul hôte.
FAQ
Peut-on saisir un masque de sous-réseau plutôt qu’un CIDR ?
En IPv4, saisissez par exemple « 172.16.5.4 255.255.240.0 » ou « 172.16.5.4/255.255.240.0 ». Les bits à 1 du masque doivent être contigus : un masque comme 255.0.255.0 est refusé.
Combien d’hôtes peut-on utiliser avec un /31 ou un /32 ?
Un /31 IPv4 contient deux adresses utilisables pour une liaison point à point, sans adresse de broadcast. Un /32 correspond à un seul hôte. Pour les préfixes de /0 à /30, le nombre d’hôtes utilisables est le nombre total d’adresses moins deux.
Pourquoi le tableau n’affiche-t-il pas tous les sous-réseaux ?
Le tableau affiche au maximum 1 024 sous-réseaux. L’export CSV peut contenir jusqu’à 65 536 lignes ; au-delà, il est tronqué. Le découpage est limité à 16 bits supplémentaires par rapport au préfixe de départ.
L’adresse IP saisie est-elle envoyée à un serveur ?
Le calcul s’effectue dans votre navigateur, sans requête réseau du calculateur. L’adresse figure toutefois dans le fragment de l’URL (#…), donc dans votre historique et les liens copiés ; ce fragment n’est pas envoyé au serveur. Le site utilise Google Analytics pour des événements d’usage, sans transmettre l’adresse saisie.