Как пользоваться
- Введите IP-адрес с префиксом CIDR в поле ввода.
- Если указали адрес без префикса, выберите его в списке «Префикс».
- Для проверки битов IPv4 включите «Показать в двоичном виде».
- Чтобы разделить сеть на подсети, выберите нужный префикс в списке «Разбить на».
Примеры
Подсеть домашнего роутера
192.168.1.10/24
Адрес: 192.168.1.10 Сеть: 192.168.1.0/24 Маска сети: 255.255.255.0 Wildcard-маска: 0.0.0.255 Широковещательный: 192.168.1.255 Первый доступный хост: 192.168.1.1 Последний доступный хост: 192.168.1.254 Всего адресов: 256 Доступные хосты: 254 Тип адреса: Частная (RFC 1918) Класс (устар.): C Целые: 3232235786 HEX: 0xC0A8010A Заданы биты хоста. Сеть: 192.168.1.0/24.
Офисная сеть с маской вместо CIDR
172.16.5.4 255.255.240.0
Адрес: 172.16.5.4 Сеть: 172.16.0.0/20 Маска сети: 255.255.240.0 Wildcard-маска: 0.0.15.255 Широковещательный: 172.16.15.255 Первый доступный хост: 172.16.0.1 Последний доступный хост: 172.16.15.254 Всего адресов: 4096 Доступные хосты: 4094 Тип адреса: Частная (RFC 1918) Класс (устар.): B Целые: 2886731012 HEX: 0xAC100504 Заданы биты хоста. Сеть: 172.16.0.0/20.
Деление блока IPv6 /48 на подсети /64
2001:db8:1234::/48
Адрес: 2001:db8:1234:: Полная запись: 2001:0db8:1234:0000:0000:0000:0000:0000 Сеть: 2001:db8:1234::/48 Маска префикса: ffff:ffff:ffff:: Диапазон адресов: 2001:db8:1234:: – 2001:db8:1234:ffff:ffff:ffff:ffff:ffff Всего адресов: 1208925819614629174706176 (2^80) Тип адреса: Документация (RFC 3849) Подсети /64: 65,536 2001:db8:1234::/64 | 2001:db8:1234:: – 2001:db8:1234:0:ffff:ffff:ffff:ffff | 18446744073709551616 … 2001:db8:1234:3ff::/64 | 2001:db8:1234:3ff:: – 2001:db8:1234:3ff:ffff:ffff:ffff:ffff | 18446744073709551616 Показано подсетей: 1,024 из 65,536.
Справочник масок подсети IPv4
Показать таблицу для /0 – /32
| Префикс | Маска сети | Wildcard | Адреса | Доступные хосты |
|---|---|---|---|---|
| /0 | 0.0.0.0 | 255.255.255.255 | 4294967296 | 4294967294 |
| /1 | 128.0.0.0 | 127.255.255.255 | 2147483648 | 2147483646 |
| /2 | 192.0.0.0 | 63.255.255.255 | 1073741824 | 1073741822 |
| /3 | 224.0.0.0 | 31.255.255.255 | 536870912 | 536870910 |
| /4 | 240.0.0.0 | 15.255.255.255 | 268435456 | 268435454 |
| /5 | 248.0.0.0 | 7.255.255.255 | 134217728 | 134217726 |
| /6 | 252.0.0.0 | 3.255.255.255 | 67108864 | 67108862 |
| /7 | 254.0.0.0 | 1.255.255.255 | 33554432 | 33554430 |
| /8 | 255.0.0.0 | 0.255.255.255 | 16777216 | 16777214 |
| /9 | 255.128.0.0 | 0.127.255.255 | 8388608 | 8388606 |
| /10 | 255.192.0.0 | 0.63.255.255 | 4194304 | 4194302 |
| /11 | 255.224.0.0 | 0.31.255.255 | 2097152 | 2097150 |
| /12 | 255.240.0.0 | 0.15.255.255 | 1048576 | 1048574 |
| /13 | 255.248.0.0 | 0.7.255.255 | 524288 | 524286 |
| /14 | 255.252.0.0 | 0.3.255.255 | 262144 | 262142 |
| /15 | 255.254.0.0 | 0.1.255.255 | 131072 | 131070 |
| /16 | 255.255.0.0 | 0.0.255.255 | 65536 | 65534 |
| /17 | 255.255.128.0 | 0.0.127.255 | 32768 | 32766 |
| /18 | 255.255.192.0 | 0.0.63.255 | 16384 | 16382 |
| /19 | 255.255.224.0 | 0.0.31.255 | 8192 | 8190 |
| /20 | 255.255.240.0 | 0.0.15.255 | 4096 | 4094 |
| /21 | 255.255.248.0 | 0.0.7.255 | 2048 | 2046 |
| /22 | 255.255.252.0 | 0.0.3.255 | 1024 | 1022 |
| /23 | 255.255.254.0 | 0.0.1.255 | 512 | 510 |
| /24 | 255.255.255.0 | 0.0.0.255 | 256 | 254 |
| /25 | 255.255.255.128 | 0.0.0.127 | 128 | 126 |
| /26 | 255.255.255.192 | 0.0.0.63 | 64 | 62 |
| /27 | 255.255.255.224 | 0.0.0.31 | 32 | 30 |
| /28 | 255.255.255.240 | 0.0.0.15 | 16 | 14 |
| /29 | 255.255.255.248 | 0.0.0.7 | 8 | 6 |
| /30 | 255.255.255.252 | 0.0.0.3 | 4 | 2 |
| /31 | 255.255.255.254 | 0.0.0.1 | 2 | 2 |
| /32 | 255.255.255.255 | 0.0.0.0 | 1 | 1 |
Сети /31 — это каналы «точка-точка» (RFC 3021) с двумя доступными адресами; /32 — один хост.
Частые вопросы
Сколько доступных адресов в подсетях /31 и /32?
В IPv4-подсети /31 доступны оба адреса, широковещательного адреса нет: это вариант для соединения точка-точка по RFC 3021. Подсеть /32 содержит один адрес хоста.
Почему для IPv6 нет широковещательного адреса?
В IPv6 широковещательные адреса не используются. Калькулятор показывает диапазон адресов всего префикса, без отдельных строк для broadcast и доступных хостов.
Почему калькулятор не принимает маску 255.0.255.0?
В маске подсети единичные биты должны идти подряд, без разрывов. Маска 255.0.255.0 нарушает это правило; маски в десятичной записи через точки поддерживаются только для IPv4.
Сколько подсетей можно получить при делении сети?
Префикс можно увеличить максимум на 16 бит, не выходя за /32 для IPv4 или /128 для IPv6. Таблица показывает до 1024 подсетей, а CSV содержит до 65 536 строк; при превышении лимита файл обрезается.
Отправляется ли введённый IP-адрес на сервер?
Расчёты выполняются в браузере без сетевых запросов со стороны инструмента. Адрес записывается в часть URL после # и остаётся в истории браузера и скопированных ссылках, но браузер не отправляет эту часть URL на сервер.